Le core team de Joomla nous informe de la mise à disposition d'une importante mise à jour de sécurité pour la branche 1.5.

Cette nouvelle version corrige une faille critique concernant l'accès à l'administration, par une modification du mot de passe administrateur

Il est indispensable de patcher le plus rapidement possible votre version, pour éviter à des personnes mal intentionnés de pirater votre site.

Consulter l'annonce officielle

Accéder à la page de téléchargement des patchs

Il est possible  de corriger cette erreur en modifiant le fichier reset.php dans le dossier  /components/com_user/models à la ligne 113 après global $mainframe; ajouter les lignes suivante :

if(strlen($token) != 32) {
    $this->setError(JText::_('INVALID_TOKEN'));
    return false;
}

Si malheureusement vous avez été victime de cette faille, vous pouvez effectuer une requète sql pour reprendre la main de votre site.

REPLACE INTO `jos_users` VALUES(62, 'Administrator', 'admin', 'Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser.', '296e21e19e0a53e6eacc64bc8cf6e134:w15sQL14fsn2V8MF pPmWZTz9LVgmZIaj', 'Super Administrator', 0, 1, 25, '2008-05-29 08:57:52', '2008-08-13 07:23:48', '', 'admin_language=\nlanguage=\neditor=\nhelpsite=\nt imezone=1\n\n');

Vous pourrez vous connecter avec les identifiants suivant  login:admin Mdp:admin

N'oubliez pas de modifier rapidement avec un nouveau mot de passe.

Source: Joomlafrance

A propos de l'auteur
Stéphane Bourderiou
Nom: Stéphane BourderiouSite Web: http://www.aide-joomla.com/
Fondateur et rédacteur en chef - Fondateur du site SFK
Webmaster en perpétuelle recherche
Derniers articles de l'auteur

  • Aucun commentaire sur cet article.
Ajouter un commentaire